Skip Menu |
Ticket metadata
The Basics
Id: 891
Status: rejected
Priority: 0/
Queue: OpenSSL-Bugs

Custom Fields
Milestone: (no value)
Subsystem: (no value)
Severity: (no value)
Broken in: (no value)

Owner: Nobody in particular
Requestors: Bruce Dubbs

More about the requestors

Bruce Dubbs

Comments about this user: No comment entered about this user
Groups this user belongs to
  • Unprivileged
  • Everyone

New reminder:

Created: Sun Jun 06 13:00:21 2004
Starts: Not set
Started: Mon Jun 30 14:21:48 2014
Last Contact: Mon Jun 30 14:21:48 2014
Due: Sun Jun 06 13:00:21 2004
Closed: Mon Jun 30 14:21:48 2014
Updated: Mon Jun 30 14:21:48 2014 by Rich Salz

Date: Fri, 04 Jun 2004 17:56:38 -0500
From: Bruce Dubbs <>
Subject: Openssl Seg Fault
Apologies if this was already posted, but we've been having email problems.
I am trying to run down a problem I am having with openssl.

When I run:

openssl ca -in test-req.pem > test-cert.pem

and give a *wrong* password for my ca key, the program
prints two debugging error messages and segfaults.
I would prefer the program just say "Bad password" and exit.

When giving a correct password, everything is fine.

I'm compiling with gcc 3.3.1 on a Linux 2.4.25 kernel.
openssl version is 0.9.7d.

My build instructions are

./config --openssldir=/etc/ssl --prefix=/usr shared
make install

I am also interested in turning off the debugging error messages. How
do I do that? I tried passing no-err to config and that did not work.


-- Bruce Dubbs

Show quoted text
OpenSSL Project
User Support Mailing List
Automated List Manager
old version, can't reproduce. please open a new ticket if this is still an issue.